or login with

Blizzard appear to have launched Diablo 3 Australian servers

19 Mar 2014  by   Paul Younger
Tweet about this on Twitter5Share on Facebook88Share on Google+0Share on Reddit0

Diablo 3 Logo

Diablo 3 players in the Oceanic region have been suffering. Since the game launched players in Australia and New Zealand have had to connect to North American servers which is hardly ideal.

Ping times to the US servers could vary between 100+ – 200+ which is terrible when your hacking your way through the mobs. Something strange has happened in the past 24 hours though, the ping has suddenly dropped to around 50. Site visitor Frantic alerted us to the changes:

“There’s something going on with Australian players. I’m logging and getting really low pings. Others have seen similar things. There’s been talk that there’s a local server being set up in Sydney. There’s been nothing from Blizzard about this though. There are numerous threads in the ANZ forum about this where one time they log in they have the normal latency of about 200-300+ and now it’s dropped to 20-70.”

“The oddest thing is, is that we’re still connected to the Americas with an American friends list. I was still talking to someone on an Oceanic WoW server (which is located in America) while I had a 30 ping in Sydney. So there’s something really weird going on.”

There has been no official update on this from Blizzard but checking the comments from other players in the region it’s looking like Blizzard has covertly launched new servers in Australia in time for the Reaper of Souls launch next week. Well done to Blizzard for finally sorting their players out with localised servers.

Update – 20 March: The servers have now been officially confirmed.

Tweet about this on Twitter5Share on Facebook88Share on Google+0Share on Reddit0
Register an IncGamers account to post comments, enter giveways and more!
You can also post through a social network or without logging in.
    
or login with

  1. David

    Yep just checked. Sitting on 40ms. Confirmed. I’ve never got below 200 ms from Blizzard previously.

    March 19, 2014 at 9:56 pm

  2. kyo
    +1

    fake ms , using proxy server

    March 20, 2014 at 2:00 am

You're too late! The comments are now closed.

Game advertisements by <a href="http://www.game-advertising-online.com" target="_blank">Game Advertising Online</a> require iframes.