Total War Rome 2 releases – Graphics issues, crashes and bugs abound

3 Sep 2013  by   Paul Younger
Tweet about this on Twitter6Share on Facebook8Share on Google+0Share on Reddit0

Total War: Rome 2 - Pontus

This morning at 8AM in the UK Total War Rome 2 unlocked on Steam much to the excitement of fans eagerly awaiting the next game in the series from Creative Assembly. However, it has not been without problems.

The Steam group is awash with complaints of poor performance, terrible textures, bugs and crashes. Now this is not unusual for a new game from CA, previous games have suffered similar problems so we shouldn’t really be surprised.

This afternoon the official forums went offline for some time which is never a great help for anyone looking or advice and Creative Assembly suggest you do the following if you’re suffering.

  • If you are experiencing low resolution textures when running on extreme, its most likely that you don’t have enough video memory.You can force an override by ticking the unlimited video memory tick box in the advanced graphics settings however this may impact performance.
  • Another thing, the vegetation alpha is an option that should be set to off for all but the most powerful rigs.
  • A workaround has been found that could help some of you: by setting your game in windows mode you shouldn’t experience texture issues any more.

If you still have this issue, please update your post stating you have tried these solutions and that it hasn’t worked. If it did work could you please update your post to state that instead?

When editing your post to confirm your issue is ongoing, please add your DxDiag as explained here and add your preferences.script.thx.

To get your preferences.script.thx:

  • Go to Start->Search and type run
  • New window will pop up and type in: appdata
  • this will open the appdata folder
  • Go to folder: Roaming
  • Go to folder: Creative Assembly
  • Go to folder: Rome2
  • Go to folder: scripts
  • open preferences.script.txt
  • post the content

We have been testing the retail version today on our ninja-bastard PCs and let’s just say performance has not been great with slow frame rates and plenty of graphical glitches and what appear to be some really obvious bugs in the early missions.

It’s not a great start for the game and it’s also one reason we are holding off on the review as these issues were identified by Peter when he previewed the game about a month ago.

One thing we have to keep in mind, and I know it’s little comfort to those experiencing problems, this is a Total War game, these problems are to be expected.

Update: We’ve added another post highlighting the latest updates from CA.

Update: Patch is incoming Friday!

Update: Peter has some tips here if you have map lag.

Update – 13 September: IncGamers Review is up

Update – 13 September: Beta patch 2 has been released

Tweet about this on Twitter6Share on Facebook8Share on Google+0Share on Reddit0

Related to this story

Register an IncGamers account to post comments or use Disqus.
You can also post via a social network.
Game advertisements by <a href="http://www.game-advertising-online.com" target="_blank">Game Advertising Online</a> require iframes.