or login with

Total War Rome 2 Patch 1 now live – Patch 2 beta on Monday

6 Sep 2013  by   Paul Younger
Tweet about this on Twitter1Share on Facebook0Share on Google+1Share on Reddit0

Total War Rome II (1)

The news just in from creative Assembly is that Total War Rome 2 Patch 1 is now live following yesterday’s beta release.

According to the update from Creative Asssembly:

“At Creative Assembly we are working flat out to fix the 2% of ROME II players reporting technical problems, it is a minority of cases but it’s a minority we remain very unhappy about and are doing all we can to get them in-game as fast as possible with the entire team working on a series of patches that will hit weekly for the immediate future”

There’s more to come as far as patches are concerned. Patch 2 is now in internal testing and a beta version will be released on Monday which CA say will fix “low-poly models viewed close-up, performance settings on certain hardware combinations and siege battle path-finding amongst other improvements”

How has it been going for you? Did patch 1 help resolve your issues?

[Update]: Patch 2′s beta has been delayed.

Tweet about this on Twitter1Share on Facebook0Share on Google+1Share on Reddit0
Register an IncGamers account to post comments, enter giveways and more!
You can also post through a social network or without logging in.
    
or login with
  1. Avatar of
    Peter Parrish
    +30

    They’re deluding themselves if they really believe only 2% of players are having issues with this game. It’s also rather dismissive and insulting.

    September 6, 2013 at 5:35 pm

    1. hilarious joe
      +3

      That’s hilarious, 2 percent of players but 100 percent of all professional editorial reviews reported issues.

      September 8, 2013 at 5:09 am

    2. Chris
      -2

      heres an insulting message.. you bogans are all idiots to be honest that are complain..

      at least this is one of the company’s who listen to their gamers and get there finger out of there butt and do something about fixing there games
      GO SEGA GO

      September 8, 2013 at 2:52 pm

  2. Kodes
    +1

    I’m glad you said it.

    September 6, 2013 at 6:02 pm

  3. Ramirez
    -1

    They’ve sold roughly 3-5 million units (They announced sales of six times the amount of Shogun 2, which is between 500k-800k, I couldn’t find an exact figure).

    So that’s 60000-100000 unhappy people. I don’t think they’re ‘deluding’ themselves, it would make the situation even worse for themselves which is something they’re avoiding. I don’t see why you’ve said it’s dismissive and insulting.

    However, that is still a lot of unhappy consumers.

    September 6, 2013 at 6:44 pm
    1. Avatar of
      Peter Parrish
      +8

      Having re-read, I’ve noticed that the sentence is rather cleverly worded. They say 2% of people are REPORTING technical issues – which is something I can believe, but that also artificially obscures the size the situation.

      There’s no indication of what counts as having “reported” an issue, and I think it’s pretty safe to say that not everybody who has encountered problems will have met whatever criteria this is.

      It’s insulting because it’s a blatant attempt at damage control; one that’s going down very poorly with the majority of people who read it as such.

      Technical problems are the tip of the iceberg too. There are AI, unit balance and User Interface issues galore with this title, which will be affecting everybody – none of this “2%” crap.

      September 6, 2013 at 6:58 pm

  4. DrSensible
    +8

    Yeah, the 2% nonsense is incredibly upsetting. There are people like myself who have not reported anything, and just follow the issues other people are reporting for a solution.

    I’ve got a decent computer, and one where I had no problem running Shogun II. Before I tried any fixes I was getting 3-4 FPS during the test, and now I’m getting 8-9 FPS. It is completely unplayable, which is a huge disappointment since I’ve been following this games release for the last two years.

    September 6, 2013 at 6:50 pm
    1. Avatar of
      Mauerbrecher
      +1

      I also think the 2% is damage control. I just bought a new pc, which isn’t particularly “high end”. I know CA programs mostly single threaded and optimised for intel. I built a pc with the FX8350 and a MSI GTX760, which isn’t bad or anything. With the test I got an average of 34 fps, with minimum of 27 and maximum of 42, most occured framerate of 33 fps. However, while scrolling over the campaign map I encounter some weird lag, as if the computer needs to load textures or something in. Also when hovering over objects lag starts to build up towards points of 1 fps for a couple of seconds until the info shows. It could be my RAM (the heatsinks are gone) but I dont know that for sure. I have installed a new cpu cooler (NH-D14) so I had to remove the heatsinks of my Corsair Revenge 1866. I asked a computer specialist/engineer and he said while I am not going to overclock the memory it doesn’t need the heat sinks at al (they are there just for looks) and the memory can withstand a lot of heat.

      So, I hope there will be a patch that makes the game more optimised. There should even be a patch in the long run so the game gets more optimised for AMD cpu’s because I am not going to buy a new CPU and MB for just this game. Because I can play ARMA3 with no lag at all and everything on the highest settings at 40 fps, which is beautiful and the best shooter I ever played!

      September 7, 2013 at 9:33 pm
  5. Avatar of
    Vladeta
    0

    How do i download this???

    September 7, 2013 at 11:40 am

  6. dougal
    -1

    OMG OMG!!! I’m getting this so EVERYONE is! OMGOMG! What a bunch of douchebags CA really are!! Who am I kidding it works fine on my computer! Also works fine on 12 of my chum’s computers. User training issue?

    September 8, 2013 at 3:15 am

  7. Anonymous Anne
    +1

    I think that allot more then 2% of people are having issues.

    But saying that i have a medicore PC and I haven’t noticed any frame issues at all (try run steam as admin it seems to help) or any other major issues.

    The only bad thing i can say about this game is the AI are incredibly fuckin dumb, really puts you off this game, makes you feel like you’re just playing by yourself with no AI at all

    September 8, 2013 at 4:20 am

  8. jerre

    2 procent is a joke evreyboduy knows that

    September 8, 2013 at 2:05 pm

  9. FullyArmedCamel

    I have a top of the line computer and while I am not having the 3-10 fps issues I have to run the game on almost minimum graphics the unreal screen jerking lag issues on the Campaign map, as far as multiplayer I have a couple of buddies who run mid to upper mid range rigs with all sorts of different hardware configs and none of them are having a good time so far. Just gut wrenching lag and horrible performance.

    Today I sat down for 5 hours and combed through the forums for fixs I must of tried and tested 30 different things and not a one worked in any sort of serious way.

    I love total war, have played every single one since original Shogun (including the debacle with Empire) but this game, its not even close to done every time I try to scroll and the screen just freezes I have to ask myself how the f— did they not catch this before release, which in turn translates to a feeling of getting a very shitty joke played on my wallet.

    September 10, 2013 at 7:33 am

  10. poo poo on you

    half measures! a game with this sort of budget and fanbase should have been properly tested before release. They sold everyone a BETA and expected patches and updates to make it all better. not good enough CA… even if it was SEGA putting pressure on them, they should have been upfront and realistic about the timeframe they had… to develop a game like this and release it in such a state is a JOKE

    September 10, 2013 at 11:41 am

  11. Frederik
    -1

    This might be a stupid question, so bare with me. But does this new patch download by it self? I am asking because I seems that I am stilling running version 1.0.0, so if it is correct that a new patch was launched last friday, why dont I have it then?

    And again, sorry for asking this, maybe, stupid question.

    September 10, 2013 at 7:57 pm
    1. Avatar of
      Peter Parrish

      Hello. Yeah, the first patch should really have auto-downloaded on Steam. It may still be calling itself version 1.0.0 for some reason?

      A couple of things you might try: right-click Rome 2 on Steam and check that under the ‘updates’ tab you have it set to ‘always keep this game up to date,’ aaand maybe got to the ‘local files’ tab and click the verify game cache button.

      You can also opt-in to Patch 1.5 by going to ‘betas’ and selecting it in the drop-down menu. That should get 1.5 downloading.

      September 10, 2013 at 8:16 pm

You're too late! The comments are now closed.

Game advertisements by <a href="http://www.game-advertising-online.com" target="_blank">Game Advertising Online</a> require iframes.